Autres versions

Vous êtes ici : Installer et exploiterPré-requis

Pré-requis logiciels

Liste des logiciels requis pour installer K-Sup

Retrouvez ici la liste des pré-requis nécessaires à l'installation de K-Sup : logiciels, versions, configurations.

Système d'exploitation

Kosmos recommande l'utilisation des dernières distributions stables de Linux. Nous garantissons le bon fonctionnement de K-Sup avec les distributions suivantes :
  • GNU Linux Debian 9 64 bits
  • Red Hat Enterprise Linux 7 64 bits
Ces distributions sont pré-équipées avec un certain nombre de composants stables qui seront par la suite mis à jour avec les patchs de sécurité. Kosmos recommande de suivre régulièrement les mises à jour de sécurité.
 

Composants logiciels à installer

Composant Versions requises
Java OpenJDK 8
Serveur HTTP Apache 2.4 avec le module mod_proxy ou mod_jk
Serveur d'application Tomcat 8.5
Serveur de base de données MariaDB 10.2
MySQL 5.7
Serveur Elastic (moteur de recherche) Elasticsearch 2.4.6 avec les plugins :
  • mapper-attachments
  • delete-by-query


Autres versions ou logiciels compatibles

Nos logiciels peuvent fonctionner avec d'autres logiciels ou versions de logiciels, mais ceux-ci ne sont pas officiellement supportés par Kosmos. Ils ont pu notamment être validés par d'autres équipes techniques utilisant K-Sup. On peut notamment citer :
  • Serveur web Nginx
  • Système CentOS
  • Environnements déployés sous Docker
  • Oracle JDK 8

Mis à jour le 12 août 2019